XamarinForms 系列課程

特別說明

2017/01/08

Xamarin FAQ 1-06 : 那些 Android SDK 套件需要使用 Android SDK Manager 來安裝呢?

問題

很多人在進行 Android 專案開發的時候,往往會遇到一些奇怪的問題,甚至在要建置專案的時候,就會產生相當多的錯誤訊息,如 Android.Support.V4.Widget.DrawerLayout.AddDrawerListener;其實,很多時候,這是您的 Android SDK Manager 並沒有安裝與設定完全。

解答

  • 請先安裝 Java JDK 1.8 以上的版本到您的電腦上
  • 在 Visual Studio 2015 中,點選功能表 工具 > 選項 > Xamarin > Android Settings
  • 請設定 Java Development Kit Location 這個欄位,指向您 JDK 1.8 版本安裝的位置,例如: C:\Program Files\Java\jdk1.8.0_102
  • 在 Visual Studio 2015 中,點選功能表 工具 > Android > Android SDK Manager
  • 在 Android SDK Manager 請確認底下項目已經確實有安裝且安裝到最新版本
    • Tools > Android SDK Tools
    • Tools > Android SDK Platform-tools
    • Tools > Android SDK Builder-tools ( 這裡僅需要安裝最新版本,舊的本版可以移除,不會有影響)
    • 每個 Android 版本內的 SDK Platform 項目要安裝 ( 在這裡建議把 Android 4.4.2 (API 19) 以上的各 Android 版本內的 SDK Platform 都安裝起來 )
    • Extras > Android Support Repository
    • Extras > Google USB Driver

沒有留言:

張貼留言